import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"arrayKey1\": (?<arrayKey1>[^\"]+),[\\n\\t ]+\"arrayKey2\": \"(?<arrayKey2>[^\"]+)\",[\\n\\t ]+\"arrayKey3\": \"(?<arrayKey3>[^\"]+)\")(?:[\\s\\S]*)(?:\"anotherKey\": \"(?<anotherKey>[^\"]+)\")";
final String string = "{\n"
+ " \"key1\": \"value1\",\n"
+ " \"key2\": \"value2\",\n"
+ " \"key3\": \"value3\",\n"
+ " \"key4\": [\n"
+ " {\n"
+ " \"arrayKey1\": 1,\n"
+ " \"arrayKey2\": \"something\",\n"
+ " \"arrayKey3\": \"somethingelse\"\n"
+ " },\n"
+ " {\n"
+ " \"arrayKey1\": 2,\n"
+ " \"arrayKey2\": \"something2\",\n"
+ " \"arrayKey3\": \"somethingelse2\"\n"
+ " },\n"
+ " {\n"
+ " \"arrayKey1\": 3,\n"
+ " \"arrayKey2\": \"something3\",\n"
+ " \"arrayKey3\": \"somethingelse3\"\n"
+ " }\n"
+ " ],\n"
+ " \"some very long text here\": \"\"\n"
+ " \"anotherKey\": \"value\",\n"
+ " \"keylast\": \"valuelast\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}