#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?$"
Local $sString = "http://example.com" & @CRLF & _
"ftp://example.com" & @CRLF & _
"http://example.com:80" & @CRLF & _
"http://example.com/{Make}/{Model}/{Year}" & @CRLF & _
"https://example.com?var1=value1" & @CRLF & _
"https://example.com?var1=value1&var2=value2" & @CRLF & _
"" & @CRLF & _
"http://example.com" & @CRLF & _
"https://example.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
"http://www.example.com:4000" & @CRLF & _
"http://255.255.255.255" & @CRLF & _
"" & @CRLF & _
"255.255.255.255" & @CRLF & _
"example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"ftp://ftp.com" & @CRLF & _
"http:/example.com" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")