use strict;
my $str = 'http://example.com
ftp://example.com
http://example.com:80
http://example.com/{Make}/{Model}/{Year}
https://example.com?var1=value1
https://example.com?var1=value1&var2=value2
http://example.com
https://example.com
http://www.example.com
http://www.example.com:4000
http://255.255.255.255
255.255.255.255
example.com
www.example.com
ftp://ftp.com
http:/example.com
';
my $regex = qr/^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}