const regex = /^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http:\\\/\\\/www\\.|https:\\\/\\\/www\\.|http:\\\/\\\/|https:\\\/\\\/)?[a-z0-9]+([\\-\\.]{1}[a-z0-9]+)*\\.[a-z]{2,5}(:[0-9]{1,5})?(\\\/.*)?$', 'igm')
const str = `http://example.com
ftp://example.com
http://example.com:80
http://example.com/{Make}/{Model}/{Year}
https://example.com?var1=value1
https://example.com?var1=value1&var2=value2
http://example.com
https://example.com
http://www.example.com
http://www.example.com:4000
http://255.255.255.255
255.255.255.255
example.com
www.example.com
ftp://ftp.com
http:/example.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}