$re = '/^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?$/im';
$str = 'http://example.com
ftp://example.com
http://example.com:80
http://example.com/{Make}/{Model}/{Year}
https://example.com?var1=value1
https://example.com?var1=value1&var2=value2
http://example.com
https://example.com
http://www.example.com
http://www.example.com:4000
http://255.255.255.255
255.255.255.255
example.com
www.example.com
ftp://ftp.com
http:/example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);