const regex = /(,[0-9]{7}[0-9A-F]{8})+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,[0-9]{7}[0-9A-F]{8})+', 'g')
const str = `C7,22801422CFE0F63 ,2280141C5EF0F63a,22801402EFD0F63b,2280138C5ED0F63c,228024329897530 ,228023829877530`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}