import re
regex = re.compile(r"(,[0-9]{7}[0-9A-F]{8})+")
test_str = "C7,22801422CFE0F63 ,2280141C5EF0F63a,22801402EFD0F63b,2280138C5ED0F63c,228024329897530 ,228023829877530"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")