// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(,[0-9]{7}[0-9A-F]{8})+").unwrap();
let string = "C7,22801422CFE0F63 ,2280141C5EF0F63a,22801402EFD0F63b,2280138C5ED0F63c,228024329897530 ,228023829877530";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}