using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\s)([^.\s]*\.[^.\s]*)(?!\S)";
string input = @"ac.def=1 and xy.z.kt='10' and k.t=1 or xy.z.kt.lm='10'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}