$re = '/(?:^|\s)([^.\s]*\.[^.\s]*)(?!\S)/m';
$str = 'ac.def=1 and xy.z.kt=\'10\' and k.t=1 or xy.z.kt.lm=\'10\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);