const regex = /(?:^|\s)([^.\s]*\.[^.\s]*)(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)([^.\\s]*\\.[^.\\s]*)(?!\\S)', 'gm')
const str = `ac.def=1 and xy.z.kt='10' and k.t=1 or xy.z.kt.lm='10'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}