import re
regex = re.compile(r"(?:^|\s)([^.\s]*\.[^.\s]*)(?!\S)", flags=re.MULTILINE)
test_str = "ac.def=1 and xy.z.kt='10' and k.t=1 or xy.z.kt.lm='10'"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")