#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)name\s*=\s*['"]?date[^>]+content\s*=\s*['"]?([^'"]*)['"]?|content\s*=\s*['"]?([^"']*)['"]?[^>]+name\s*=\s*['"]?date['"]?"
Local $sString = " <meta name="keywords" content="People, Royals" />" & @CRLF & _
" <meta name="news_keywords" content="william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans" />" & @CRLF & _
" <meta name="author" content="Blick" />" & @CRLF & _
"<meta name="date" content="2018-04-23T14:20:42+0200" />" & @CRLF & _
"<meta name="robots" content="index,follow,noodp,noarchive" />" & @CRLF & _
" <meta name="contentId" content="8171954" />" & @CRLF & _
" <meta name="cXenseParse:recs:articleid" content="8171954"/>" & @CRLF & _
"<meta name="contentType" content="news" />" & @CRLF & _
" <meta name="cXenseParse:rag-pagetype" content="news"/>" & @CRLF & _
"<meta name="contentPool" content="web|mobile|app" />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")