import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)name\\s*=\\s*['\"]?date[^>]+content\\s*=\\s*['\"]?([^'\"]*)['\"]?|content\\s*=\\s*['\"]?([^\"']*)['\"]?[^>]+name\\s*=\\s*['\"]?date['\"]?";
final String string = " <meta name=\"keywords\" content=\"People, Royals\" />\n"
+ " <meta name=\"news_keywords\" content=\"william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans\" />\n"
+ " <meta name=\"author\" content=\"Blick\" />\n"
+ "<meta name=\"date\" content=\"2018-04-23T14:20:42+0200\" />\n"
+ "<meta name=\"robots\" content=\"index,follow,noodp,noarchive\" />\n"
+ " <meta name=\"contentId\" content=\"8171954\" />\n"
+ " <meta name=\"cXenseParse:recs:articleid\" content=\"8171954\"/>\n"
+ "<meta name=\"contentType\" content=\"news\" />\n"
+ " <meta name=\"cXenseParse:rag-pagetype\" content=\"news\"/>\n"
+ "<meta name=\"contentPool\" content=\"web|mobile|app\" />\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}