import Foundation
let pattern = #"(?i)name\s*=\s*['"]?date[^>]+content\s*=\s*['"]?([^'"]*)['"]?|content\s*=\s*['"]?([^"']*)['"]?[^>]+name\s*=\s*['"]?date['"]?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<meta name="keywords" content="People, Royals" />
<meta name="news_keywords" content="william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans" />
<meta name="author" content="Blick" />
<meta name="date" content="2018-04-23T14:20:42+0200" />
<meta name="robots" content="index,follow,noodp,noarchive" />
<meta name="contentId" content="8171954" />
<meta name="cXenseParse:recs:articleid" content="8171954"/>
<meta name="contentType" content="news" />
<meta name="cXenseParse:rag-pagetype" content="news"/>
<meta name="contentPool" content="web|mobile|app" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)