#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:" & @CRLF & _
" (?<a>.*serverA\.company\.com.*\s+iburst.*)" & @CRLF & _
" |(?<z>.*serverZ\.company\.com.*\s+iburst.*)" & @CRLF & _
" |(?<d>.*serverD\.company\.com.*\s+iburst.*)" & @CRLF & _
" |[^\n]*(?:\n|$)" & @CRLF & _
")++" & @CRLF & _
"(?(a)(?(z)(?(d)(*ACCEPT))))(*SKIP)(*F)"
Local $sString = "irrelevant_directive = 0" & @CRLF & _
"" & @CRLF & _
"# Comment" & @CRLF & _
"server serverA.company.com iburst" & @CRLF & _
"" & @CRLF & _
"additional_directive = yes" & @CRLF & _
"" & @CRLF & _
"server serverZ.company.com iburst" & @CRLF & _
"server serverD.company.com iburst" & @CRLF & _
"" & @CRLF & _
"# Additional Comment" & @CRLF & _
"final_directive = true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")