// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?:
(?<a>.*serverA\.company\.com.*\s+iburst.*)
|(?<z>.*serverZ\.company\.com.*\s+iburst.*)
|(?<d>.*serverD\.company\.com.*\s+iburst.*)
|[^\n]*(?:\n|$)
)++
(?(a)(?(z)(?(d)(*ACCEPT))))(*SKIP)(*F)").unwrap();
let string = "irrelevant_directive = 0
# Comment
server serverA.company.com iburst
additional_directive = yes
server serverZ.company.com iburst
server serverD.company.com iburst
# Additional Comment
final_directive = true";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}