$re = '/(?:
(?<a>.*serverA\.company\.com.*\s+iburst.*)
|(?<z>.*serverZ\.company\.com.*\s+iburst.*)
|(?<d>.*serverD\.company\.com.*\s+iburst.*)
|[^\n]*(?:\n|$)
)++
(?(a)(?(z)(?(d)(*ACCEPT))))(*SKIP)(*F)/x';
$str = 'irrelevant_directive = 0
# Comment
server serverA.company.com iburst
additional_directive = yes
server serverZ.company.com iburst
server serverD.company.com iburst
# Additional Comment
final_directive = true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);