package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
(?<a>.*serverA\.company\.com.*\s+iburst.*)
|(?<z>.*serverZ\.company\.com.*\s+iburst.*)
|(?<d>.*serverD\.company\.com.*\s+iburst.*)
|[^\n]*(?:\n|$)
)++
(?(a)(?(z)(?(d)(*ACCEPT))))(*SKIP)(*F)`)
var str = `irrelevant_directive = 0
# Comment
server serverA.company.com iburst
additional_directive = yes
server serverZ.company.com iburst
server serverD.company.com iburst
# Additional Comment
final_directive = true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}