using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:My Add no|DATA|MASKEDDATA|masked 111)\b";
string input = @"I am masked 111
I am My Add No
I am My add
I am My MASKEDDATA";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}