const regex = new RegExp('\\b(?:My Add no|DATA|MASKEDDATA|masked 111)\\b', 'gi')
const str = `I am masked 111
I am My Add No
I am My add
I am My MASKEDDATA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}