// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(?:My Add no|DATA|MASKEDDATA|masked 111)\b").unwrap();
let string = "I am masked 111
I am My Add No
I am My add
I am My MASKEDDATA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}