re = /\b(?:My Add no|DATA|MASKEDDATA|masked 111)\b/i
str = 'I am masked 111
I am My Add No
I am My add
I am My MASKEDDATA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end