import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w!#$%&'*=?^_+-`\\{|\\}~]+[@]+[a-zA-Z]+[.]+[a-zA-Z]+[.]?+[a-zA-Z]+$";
final String string = "douglas@gmail.com\n"
+ "contato@estadão.com.br\n"
+ "admin@site.com\n"
+ "pedro@coca-cola.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}