$re = '/^[\w!#$%&\'*=?^_+-`{|}~]+[@]+[a-zA-Z]+[.]+[a-zA-Z]+[.]?+[a-zA-Z]+$/m';
$str = 'douglas@gmail.com
contato@estadão.com.br
admin@site.com
pedro@coca-cola.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);