// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)1_c Anruf/Meldung am \(Datum\)\s*:+\s*([^\r\n]*\S)").unwrap();
let string = "1_c Anruf/Meldung am (Datum): 04.Mai.2020 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}