#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(?>\d|(?<!\d)\h){8}\d(?!\d)"
Local $sString = " " & @CRLF & _
"123456789" & @CRLF & _
"kfasdf 3456789asdf" & @CRLF & _
"a 1" & @CRLF & _
"" & @CRLF & _
"12345 789" & @CRLF & _
"1 9" & @CRLF & _
"a 678a" & @CRLF & _
"" & @CRLF & _
" 123456789 " & @CRLF & _
"a123456789 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")