using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(?>\d|(?<!\d)\h){8}\d(?!\d)";
string input = @"
123456789
kfasdf 3456789asdf
a 1
12345 789
1 9
a 678a
123456789
a123456789 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}