$re = '/(?<!\d)(?>\d|(?<!\d)\h){8}\d(?!\d)/m';
$str = '
123456789
kfasdf 3456789asdf
a 1
12345 789
1 9
a 678a
123456789
a123456789 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);