const regex = /(?<!\d)(?>\d|(?<!\d)\h){8}\d(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)(?>\\d|(?<!\\d)\\h){8}\\d(?!\\d)', 'gm')
const str = `
123456789
kfasdf 3456789asdf
a 1
12345 789
1 9
a 678a
123456789
a123456789 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}