# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w|!|#|\$|%|&|\/|\\|\(|\)|=|_|-|\+|\*|,|\.|(?<=\\)"")+|(?<!\\)""(\w|!|#|\$|%|&|\/|\\|\(|\)|=|_|-|\+|\*|,|\.|(?<=\\)""|\s)+(?<!\\)""/\n$0/ig;t' <<< "12d m1 M1 \"kia ita-_//()/&%),.+=/7\lia\" *2 Y*G \"stan_the man\" -- \"\\"fef 1234\" \\"fef 1234\\" \"asdf\" \"as\\"asdf\" as\\"df asdf"