import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w|!|#|\\$|%|&|/|\\\\|\\(|\\)|=|_|-|\\+|\\*|,|\\.|(?<=\\\\)\"\")+|(?<!\\\\)\"\"(\\w|!|#|\\$|%|&|/|\\\\|\\(|\\)|=|_|-|\\+|\\*|,|\\.|(?<=\\\\)\"\"|\\s)+(?<!\\\\)\"\"";
final String string = "12d m1 M1 \"kia ita-_//()/&%),.+=/7\\lia\" *2 Y*G \"stan_the man\" -- \"\\\"fef 1234\" \\\"fef 1234\\\" \"asdf\" \"as\\\"asdf\" as\\\"df asdf";
final String subst = "\\n$0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}