using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w|!|#|\$|%|&|/|\\|\(|\)|=|_|-|\+|\*|,|\.|(?<=\\)"")+|(?<!\\)""(\w|!|#|\$|%|&|/|\\|\(|\)|=|_|-|\+|\*|,|\.|(?<=\\)""|\s)+(?<!\\)""";
string substitution = @"\n$0";
string input = @"12d m1 M1 ""kia ita-_//()/&%),.+=/7\lia"" *2 Y*G ""stan_the man"" -- ""\""fef 1234"" \""fef 1234\"" ""asdf"" ""as\""asdf"" as\""df asdf";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}