use strict;
my $str = '12d m1 M1 "kia ita-_//()/&%),.+=/7\\lia" *2 Y*G "stan_the man" -- "\\"fef 1234" \\"fef 1234\\" "asdf" "as\\"asdf" as\\"df asdf';
my $regex = qr/(\w|!|#|\$|%|&|/|\\|\(|\)|=|_|-|\+|\*|,|\.|(?<=\\)"")+|(?<!\\)""(\w|!|#|\$|%|&|/|\\|\(|\)|=|_|-|\+|\*|,|\.|(?<=\\)""|\s)+(?<!\\)""/ip;
my $subst = '\\n$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";