# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^( *(?:\"[^\"]*\" *, *){3})\"[^\"]*\"|\"[^\"]*\"((?: *, *\"[^\"]*\"){3} *)$/$1""$2/gm;t' <<< "\"00001\",\"Open\",\"2020-10-23 12:45\",\"2022-10-20 15:48\",\"Error not found\",\"Alex Smith\",\"NO ERROR\",\"ErrorApp\",\"FOB\",\"CNSHA\",\"GB\",\"Plane\",\"MODEL\",\"2020-10-24 00:00\",\"New\",\"1\",\"\",\"2022-10-20 15:48\", \"Yes\", \"No\", \"Completed\""