import Foundation
let pattern = #"^( *(?:\"[^\"]*\" *, *){3})\"[^\"]*\"|\"[^\"]*\"((?: *, *\"[^\"]*\"){3} *)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""00001","Open","2020-10-23 12:45","2022-10-20 15:48","Error not found","Alex Smith","NO ERROR","ErrorApp","FOB","CNSHA","GB","Plane","MODEL","2020-10-24 00:00","New","1","","2022-10-20 15:48", "Yes", "No", "Completed""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1""$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)