import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^( *(?:\\\"[^\\\"]*\\\" *, *){3})\\\"[^\\\"]*\\\"|\\\"[^\\\"]*\\\"((?: *, *\\\"[^\\\"]*\\\"){3} *)$";
final String string = "\"00001\",\"Open\",\"2020-10-23 12:45\",\"2022-10-20 15:48\",\"Error not found\",\"Alex Smith\",\"NO ERROR\",\"ErrorApp\",\"FOB\",\"CNSHA\",\"GB\",\"Plane\",\"MODEL\",\"2020-10-24 00:00\",\"New\",\"1\",\"\",\"2022-10-20 15:48\", \"Yes\", \"No\", \"Completed\"";
final String subst = "$1\"\"$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}