#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?usi)^([^\.]+\.)"
Local $sString = "Тестовое предложение. Ещё одно."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)