import re
regex = re.compile(r"^([^\.]+\.)", flags=re.UNICODE | re.DOTALL | re.IGNORECASE)
test_str = "Тестовое предложение. Ещё одно."
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)