const regex = /^([^\.]+\.)/usi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\.]+\\.)', 'usi')
const str = `Тестовое предложение. Ещё одно.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);