use strict;
my $str = 'Тестовое предложение. Ещё одно.';
my $regex = qr/^([^\.]+\.)/usip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";