import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Opponent: ).*?(?= Bus| Dismissal)";
final String string = "Type: Game Opponent: Balder-Woody Area School District Bus: 2:00PM Dismissal: 1:30PM Est.return:\n\n"
+ "Type: Game Opponent: Balder-Woody Area School District Dismissal: 1:30PM Bus: 2:00PM Est.return:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}