re = /(?<=Opponent: ).*?(?= Bus| Dismissal)/m
str = 'Type: Game Opponent: Balder-Woody Area School District Bus: 2:00PM Dismissal: 1:30PM Est.return:
Type: Game Opponent: Balder-Woody Area School District Dismissal: 1:30PM Bus: 2:00PM Est.return:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end