const regex = /\s*\{\{source\|(?>[^{}]|(\{\{(?:[^{}]++|(?1))*}}))*}}\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\{\\{source\\|(?>[^{}]|(\\{\\{(?:[^{}]++|(?1))*}}))*}}\\s*', 'gm')
const str = `# Test is a cool word {{source|{{nom w pc|Chantal|Bouchard}}, ''La langue et le nombril'', Presses de l'Université de Montréal (PUM), 2020, p. 174}}.
# Test is a cool word {{source|Nicolas|Daniel, Presses de l'Université de Montréal 4}}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);