import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*getBalance";
final String string = "https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance\n"
+ "https://smska.net/stubs/handler_api.php?api_key=582ada54a8e59f4ee7fb8a01f530ca55&action=getNumber\n"
+ "https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance\n"
+ "https://smska.net/stubs/handler_api.php?api_key=553ada54a8e53f7ee7fb8a07f550ca23&action=getStatus\n"
+ "https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance\n"
+ "https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}