const regex = /^.*getBalance/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*getBalance', 'gm')
const str = `https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=582ada54a8e59f4ee7fb8a01f530ca55&action=getNumber
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=553ada54a8e53f7ee7fb8a07f550ca23&action=getStatus
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}