use strict;
my $str = 'https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=582ada54a8e59f4ee7fb8a01f530ca55&action=getNumber
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=553ada54a8e53f7ee7fb8a07f550ca23&action=getStatus
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance';
my $regex = qr/^.*getBalance/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}