// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*getBalance").unwrap();
let string = "https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=582ada54a8e59f4ee7fb8a01f530ca55&action=getNumber
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=553ada54a8e53f7ee7fb8a07f550ca23&action=getStatus
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance
https://smska.net/stubs/handler_api.php?api_key=583ada77a8e53f4ee7fb2307f550ca33&action=getBalance";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}