using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--\s+\d+\s+--\s+(.*?), US\b";
string input = @"[Radius: 4000 mi.] -- 61362 -- Spring Valley, IL, US";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}