package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)--\s+\d+\s+--\s+(.*?), US\b`)
var str = `[Radius: 4000 mi.] -- 61362 -- Spring Valley, IL, US`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}